db-move: moved libdex from [staging] to [testing] (x86_64)
[arch-packages.git] / gnome-weather / trunk / PKGBUILD
bloba0ce4b5db4dd2d91eea26c572861e5e34ed0ea46
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-weather
4 pkgver=44.0
5 pkgrel=1
6 pkgdesc="Access current weather conditions and forecasts"
7 url="https://wiki.gnome.org/Apps/Weather"
8 arch=(any)
9 license=(GPL)
10 depends=(
11   geoclue
12   gjs
13   gtk4
14   libadwaita
15   libgweather-4
17 makedepends=(
18   appstream-glib
19   git
20   gobject-introspection
21   meson
23 groups=(gnome)
24 _commit=120d816ee05a466555a63eb0cad762b960e8f425  # tags/44.0^0
25 source=("git+https://gitlab.gnome.org/GNOME/gnome-weather.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
37 build() {
38   arch-meson $pkgname build
39   meson compile -C build
42 check() {
43   meson test -C build --print-errorlogs
46 package() {
47   meson install -C build --destdir "$pkgdir"
50 # vim:set sw=2 sts=-1 et: