1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux at free.fr>
3 # Contributor: Bartlomiej Piotrowski <nospam at bpiotrowski dot pl>
4 # Contributor: Patrick McCarty <pnorcks at gmail dot com>
9 pkgdesc='A Markdown implementation written in C'
11 url="https://www.pell.portland.or.us/~orc/Code/discount/"
12 license=('custom:BSD')
13 source=($pkgname-$pkgver.tar.gz::"https://github.com/Orc/discount/archive/v$pkgver.tar.gz"
14 discount-ldflags.patch::"https://github.com/Orc/discount/commit/55cea9c5.patch")
15 sha256sums=('72c1325ddfc40871d6810f1e272cf2d45b361f26357eb38f170fd04d737bb9f2'
16 '7eced2472fdbe25badc13c35dfd6920b68b5a208889ee031ef0c060c093cc89b')
20 patch -d $pkgname-$pkgver -p1 -i ../discount-ldflags.patch # Honor system ldflags
27 --enable-all-features \
37 sed -e 's|/sbin/ldconfig|/sbin/ldconfig -n|' -i librarian.sh
39 make DESTDIR="$pkgdir" install.everything
40 install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE