OCaml 4.14.0 rebuild
[arch-packages.git] / freecell-solver / trunk / PKGBUILD
blobb7c7f2284a6d5b28437cfb98f2c5f38e47f501a0
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=freecell-solver
4 pkgver=6.6.0
5 pkgrel=1
6 pkgdesc='A program that automatically solves layouts of Freecell and similar variants of Card Solitaire'
7 arch=(x86_64)
8 url='https://fc-solve.shlomifish.org'
9 license=(MIT)
10 depends=(bash)
11 makedepends=(cmake gperf perl-moo perl-path-tiny perl-template-toolkit python-random2 python-six python-pysol_cards rinutils)
12 optdepends=('python-random2: for the Python interface' 'python-six: for the Python interface'
13             'python-pysol_cards: for the Python interface')
14 source=(https://fc-solve.shlomifish.org/downloads/fc-solve/$pkgname-$pkgver.tar.xz)
15 sha256sums=('16b58e78d44d95d0ff1b10496dd2d8bd27de592a26f8f874e95a1d841309048c')
17 build() {
18   cmake -B build -S $pkgname-$pkgver \
19     -DCMAKE_INSTALL_PREFIX=/usr \
20     -DFCS_WITH_TEST_SUITE=OFF \
21     -DBUILD_STATIC_LIBRARY=OFF
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
27   install -Dm644 $pkgname-$pkgver/COPYING.html "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.html