OCaml 4.14.0 rebuild
[arch-packages.git] / gtkspell / trunk / PKGBUILD
blobefc2d362f9b06f7050bb87ea6054a08c77b1c497
1 # Maintainer: Roman Kyrylych <roman@archlinux.org>
2 # Contributer: Ben <ben@benmazer.net>
4 pkgname=gtkspell
5 pkgver=2.0.16
6 pkgrel=8
7 url="http://gtkspell.sourceforge.net/"
8 pkgdesc="Provides word-processor-style highlighting and replacement of misspelled words in a GtkTextView widget"
9 arch=('x86_64')
10 license=('GPL')
11 depends=('gtk2' 'enchant')
12 makedepends=('intltool' 'gtk-doc')
13 validpgpkeys=('7C70E4D9927061BD840E82DB6BA6197569B23319') #Daniel Atallah <daniel.atallah@gmail.com>
14 source=(https://downloads.sourceforge.net/sourceforge/gtkspell/${pkgname}-${pkgver}.tar.gz{,.asc}
15         enchant-2.diff)
16 sha256sums=('8fc7dc560167b2cb7193e76aca625a152dc19b0ebf49816b78539cbb90d80d02'
17             'SKIP'
18             '52e693590161bc285ec46a2beece802f47c7ede65ec0b72ffa224ab0db176bad')
20 prepare() {
21   cd $pkgname-$pkgver
23   # enchant 2.2
24   patch -Np1 -i ../enchant-2.diff
26   gtkdocize
27   autoreconf -fvi
30 build() {
31   cd $pkgname-$pkgver
32   ./configure --prefix=/usr --disable-static
33   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
34   make
37 package() {
38   cd $pkgname-$pkgver
39   make DESTDIR="${pkgdir}" install