upgpkg: sbcl 2.2.5-1
[arch-packages.git] / cpio / trunk / PKGBUILD
blob13d23ecbb0f3c36172fd1e483c8ee6c6faf2797d
1 # Maintainer: judd <jvinet@zeroflux.org>
2 pkgname=cpio
3 pkgver=2.13
4 pkgrel=2
5 pkgdesc="A tool to copy files into or out of a cpio or tar archive"
6 arch=(x86_64)
7 license=('GPL')
8 url="https://www.gnu.org/software/cpio"
9 depends=('glibc')
10 source=(https://ftp.gnu.org/gnu/cpio/cpio-${pkgver}.tar.gz{,.sig})
11 md5sums=('389c5452d667c23b5eceb206f5000810'
12          'SKIP')
13 validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732') # Sergey Poznyakoff <gray@gnu.org>
15 build() {
16   cd ${pkgname}-${pkgver}
17   CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
18   ./configure --prefix=/usr --mandir=/usr/share/man
19   make
22 check() {
23   cd ${pkgname}-${pkgver}
24   make check
27 package() {
28   cd ${pkgname}-${pkgver}
29   make DESTDIR="${pkgdir}" install
30   rm -f "${pkgdir}/usr/bin/mt" "${pkgdir}/pkg/usr/share/man/man1/mt.1"
31   rm -rf "${pkgdir}/usr/libexec"
32   rm -f "${pkgdir}/usr/share/man/man8/rmt.8"
33   # remove infodir
34   rm "$pkgdir/usr/share/info/dir"