upgpkg: sbcl 2.2.5-1
[arch-packages.git] / hunspell / trunk / PKGBUILD
blob7eb0c4f0f509dc1d6e21443dd6addb2f4e015a66
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
4 pkgname=hunspell
5 pkgver=1.7.0
6 pkgrel=4
7 pkgdesc="Spell checker and morphological analyzer library and program"
8 arch=('x86_64')
9 url="https://hunspell.github.io/"
10 license=('GPL' 'LGPL' 'MPL')
11 depends=('gcc-libs' 'readline')
12 optdepends=('perl: for ispellaff2myspell')
13 source=($pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz
14         hunspell_buildfix.diff::https://github.com/hunspell/hunspell/commit/2f9e34d13312dbf705f7e1316ca364be13640e6c.patch
15         hunspell_buildfix2.diff::https://patch-diff.githubusercontent.com/raw/hunspell/hunspell/pull/762.patch)
16 sha256sums=('bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a'
17             'SKIP'
18             'SKIP')
20 prepare() {
21   cd hunspell-$pkgver
23   # build fix
24   patch -Np1 -i ../hunspell_buildfix.diff
25   patch -Np1 -i ../hunspell_buildfix2.diff
27   autoreconf -vfi
30 build() {
31   cd hunspell-$pkgver
32   ./configure --prefix=/usr --disable-static \
33         --with-ui --with-readline # --with-experimental breaks build in this release
34   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
35   make
38 check() {
39   cd hunspell-$pkgver
40   make check
43 package() {
44   cd hunspell-$pkgver
45   make DESTDIR="$pkgdir" install
46   
47   # add generic hunspell.so for development and projects not using pkgconfig flags - FS#30592
48   pushd "$pkgdir"/usr/lib
49   ln -s libhunspell-?.?.so libhunspell.so
50   popd