upgpkg: sbcl 2.2.5-1
[arch-packages.git] / presentproto / trunk / PKGBUILD
blob27c7d36d8898cb749fc4f8f3e1f287c5738bef62
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=presentproto
4 pkgver=1.1
5 pkgrel=1
6 pkgdesc="X11 Present protocol specification"
7 arch=('any')
8 url="https://xorg.freedesktop.org/"
9 license=('custom')
10 source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2
11         COPYING)
12 sha256sums=('f69b23a8869f78a5898aaf53938b829c8165e597cda34f06024d43ee1e6d26b9'
13             '5e46864ede2fda46c3cb7cfe3a7b9f9e4bd36d8d21d8010a284caa64b81d465a')
15 build() {
16         cd $pkgname-$pkgver
17         ./configure --prefix=/usr
18         make
21 package() {
22         cd $pkgname-$pkgver
23         make DESTDIR="$pkgdir/" install
24         
25     # license is still missing
26     # COPYING is taken from top of /usr/include/X11/extensions/presentproto.h
27     install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
28     install -m644 ${srcdir}/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"