archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gdb / trunk / PKGBUILD
blobac84cd0be6c64ddd5a178bcabe4d3dc8d1756612
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Jan de Groot <jgc@archlinux.org>
6 pkgbase=gdb
7 # gdb-common is a package that contains files common for all cross compiled versions
8 # of gdb (for arm/avr/...)
9 pkgname=(gdb gdb-common)
10 pkgver=11.2
11 pkgrel=1
12 pkgdesc='The GNU Debugger'
13 arch=(x86_64)
14 url='https://www.gnu.org/software/gdb/'
15 license=(GPL3)
16 makedepends=(glibc gcc-libs texinfo python guile ncurses expat xz mpfr source-highlight
17              readline)
18 source=(https://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.xz{,.sig})
19 sha1sums=('7c72b1d4a38bb6e155aaad29f4c1abf818b4595d'
20           'SKIP')
21 b2sums=('66ce7e12c99c33c8b4e6ababa673204aab525e72c90ba54cc34a5fd69948a09dc2a9ef2050764b2464544231b1d1a6431279c2877388551ca6fbf384a3f9b464'
22         'SKIP')
23 validpgpkeys=('F40ADB902B24264AA42E50BF92EDB04BFF325CF3') # Joel Brobecker
25 prepare() {
26   cd gdb-$pkgver
28   # hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
29   sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
32 build() {
33   cd gdb-$pkgver
35   mkdir -p build && cd build
36   ../configure \
37     --prefix=/usr \
38     --disable-nls \
39     --enable-source-highlight \
40     --enable-tui \
41     --with-system-readline \
42     --with-python=/usr/bin/python \
43     --with-guile=guile-2.2 \
44     --with-system-gdbinit=/etc/gdb/gdbinit
45   make
48 package_gdb-common() {
49   depends=(python guile)
51   cd gdb-$pkgver/build
52   make -C gdb/data-directory DESTDIR="$pkgdir" install
55 package_gdb() {
56   depends=(glibc ncurses libncursesw.so gcc-libs expat xz mpfr source-highlight gdb-common=$pkgver
57            readline libreadline.so guile python libelf)
58   backup=(etc/gdb/gdbinit)
60   cd gdb-$pkgver/build
61   make -C gdb DESTDIR="$pkgdir" install
62   make -C gdbserver DESTDIR="$pkgdir" install
64   # install "custom" system gdbinit
65   install -dm 755 "$pkgdir/etc/gdb"
66   touch "$pkgdir/etc/gdb/gdbinit"
68   # comes from gdb-common
69   rm -r "$pkgdir/usr/share/gdb/"
72 # vim: ts=2 sw=2 et: