archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-io-html / trunk / PKGBUILD
blobdfbd2219c457bf48b4d564b153d80f0861595975
1 # Maintainer: Felix Yan <felixonmars@gmail.com>
3 pkgname=perl-io-html
4 pkgver=1.004
5 pkgrel=2
6 pkgdesc="Open an HTML file with automatic charset detection"
7 arch=('any')
8 url='https://search.cpan.org/dist/IO-HTML'
9 depends=('perl')
10 license=('PerlArtistic' 'GPL')
11 options=('!emptydirs')
12 source=(https://search.cpan.org/CPAN/authors/id/C/CJ/CJM/IO-HTML-$pkgver.tar.gz)
13 sha512sums=('564fba7cfb50ef1cc78fa9e2b2200a20e305d098b8ceeb6f8478f0275cc48e4fb069386f5c318bc9deb43a5d590a78a995c04100bd440340f5c990eadc76a70f')
15 build() {
16   export PERL_MM_USE_DEFAULT=1 PERL_MM_OPT="INSTALLDIRS=vendor" \
17     PERL_MB_OPT="--installdirs vendor"
18   cd IO-HTML-$pkgver
19   perl Makefile.PL
20   make 
23 check() {
24   cd IO-HTML-$pkgver
25   make test
28 package() {
29   cd IO-HTML-$pkgver
30   make DESTDIR="$pkgdir" install