archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ethtool / trunk / PKGBUILD
blobf0052820167787eb9205d7a0025fa519cbd75713
1 # Maintainer : Ionut Biru <ibiru@archlinux.org>
2 # Contributor: Paul Mattal <paul@archlinux.org>
3 # Contributor: Martin Kemp <mdkemp@elys.com>
5 pkgname=ethtool
6 pkgver=6.2
7 pkgrel=1
8 epoch=1
9 pkgdesc="Utility for controlling network drivers and hardware"
10 arch=('x86_64')
11 url="https://www.kernel.org/pub/software/network/ethtool/"
12 license=('GPL')
13 depends=('glibc' 'libmnl')
14 source=(https://www.kernel.org/pub/software/network/$pkgname/$pkgname-$pkgver.tar.{xz,sign})
15 sha256sums=('86df0114064d4d73f6bf72bf03e85c33964a519ee0c1d1ba65005ad2d0e570e1'
16             'SKIP')
17 validpgpkeys=(CE4A4D080F0D304F23B9EBDD972D5BF4DC613806  # John W. Linville <linville@kernel.org>
18               D2CB120AB45957B721CD9596F4554567B91DE934) # Michal Kubecek <mkubecek@suse.cz>
20 build() {
21     cd $pkgname-$pkgver
22     ./configure --prefix=/usr --mandir=/usr/share/man --sbindir=/usr/bin
23     make
26 check() {
27     cd $pkgname-$pkgver
28     make check
31 package() {
32     cd $pkgname-$pkgver
33     make DESTDIR="$pkgdir" install