archrelease: copy trunk to extra-x86_64
[arch-packages.git] / moc / repos / extra-x86_64 / PKGBUILD
blob04209be8a4c548ee79846ada1aa016bb5a93f331
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=moc
4 pkgver=2.5.2
5 pkgrel=8
6 epoch=1
7 pkgdesc="An ncurses console audio player designed to be powerful and easy to use"
8 arch=('x86_64')
9 url="https://moc.daper.net/"
10 license=('GPL')
11 depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
12 makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
13 optdepends=('speex: for using the speex plugin'
14             'ffmpeg4.4: for using the ffmpeg plugin'
15             'taglib: for using the musepack plugin'
16             'libmpcdec: for using the musepack plugin'
17             'wavpack: for using the wavpack plugin'
18             'faad2: for using the aac plugin'
19             'libmodplug: for using the modplug plugin')
20 source=(http://ftp.daper.net/pub/soft/moc/stable/${pkgname}-${pkgver}.tar.bz2{,.sig}
21         moc-ffmpeg4.patch
22         moc-https.patch)
23 sha256sums=('f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08'
24             'SKIP'
25             'f1a12d7d2e8269974487a2ffb011e87d9a6c5c06e2a47d1312d5965c98f050ea'
26             'd5ace9820974912e4f3d9361ad5d03d1d655348f17c9710dff527020101e98fa')
27 validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
29 prepare() {
30   cd $pkgname-$pkgver
31   patch -p0 -i ../moc-ffmpeg4.patch # Fix build with ffmpeg 4
32   patch -p0 -i ../moc-https.patch   # Allow https for urls https://moc.daper.net/node/1872
35 build() {
36   cd ${pkgname}-${pkgver}
37   export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
38   ./configure --prefix=/usr --without-rcc \
39     --with-oss --with-alsa --with-jack --with-aac --with-mp3 \
40     --with-musepack --with-vorbis --with-flac --with-wavpack \
41     --with-sndfile --with-modplug --with-ffmpeg --with-speex \
42     --with-samplerate --with-curl  --disable-cache --disable-debug
43   make
46 package() {
47   cd ${pkgname}-${pkgver}
48   make DESTDIR="${pkgdir}" install