archrelease: copy trunk to extra-x86_64
[arch-packages.git] / mdds / trunk / PKGBUILD
blobab4c344b0034bc4bbabd7c4b24e62e6c29e77a68
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: kusakata <shohei atmark kusakata period com>
4 pkgname=mdds
5 pkgver=2.0.3
6 pkgrel=1
7 pkgdesc="A collection of multi-dimensional data structures and indexing algorithms"
8 arch=('any')
9 url="https://gitlab.com/mdds/mdds"
10 license=('MIT')
11 checkdepends=('boost')
12 #source=(https://gitlab.com/mdds/mdds/repository/archive.tar.gz?ref=${pkgver})
13 source=(https://kohei.us/files/mdds/src/${pkgname}-${pkgver}.tar.xz)
14 # checksums listed there - https://gitlab.com/mdds/mdds/-/releases
15 sha256sums=('6c01cdbd7f662a7adee5a6879d31130815fd31048d940f1b780ed67b719fc8e4')
17 build() {
18   cd ${pkgname}-${pkgver}
19   ./autogen.sh --prefix=/usr
20   # make
23 check() {
24   cd ${pkgname}-${pkgver}
25   make check
28 package() {
29   cd ${pkgname}-${pkgver}
30   make DESTDIR="${pkgdir}" install
31   install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"