archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-mail-authenticationresults / trunk / PKGBUILD
blob2278f6366eee9ff5452897a3904e6ef78c22f55f
1 # Maintainer: Florian Pritz <bluewind@xinu.at>
3 pkgname=perl-mail-authenticationresults
4 pkgver=2.20210915
5 pkgrel=2
6 pkgdesc='Object Oriented Authentication-Results Headers'
7 arch=(any)
8 license=(PerlArtistic GPL)
9 options=(!emptydirs)
10 depends=('perl>=5.8' perl-clone perl-json)
11 checkdepends=(perl-test-exception)
12 url=https://metacpan.org/release/Mail-AuthenticationResults
13 source=("https://cpan.metacpan.org/authors/id/M/MB/MBRADSHAW/Mail-AuthenticationResults-$pkgver.tar.gz")
14 md5sums=(be69b84e300e6d33b5c07fe3b7b6ec21)
15 sha512sums=(c1f1149853fd2a30116f70f126bc9822f4d085b030c5e09aec273792888c67ae141dff8c9c2368d21d692b3ca409bab89fef44d6ba0a40c9fe34b845568c570b)
16 _ddir="Mail-AuthenticationResults-$pkgver"
18 build()
20   cd "$srcdir/$_ddir"
21   export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
22   unset PERL5LIB PERL_MM_OPT
23   /usr/bin/perl Makefile.PL
24   make
27 check()
29   cd "$srcdir/$_ddir"
30   export PERL_MM_USE_DEFAULT=1
31   unset PERL5LIB
32   make test
35 package()
37   cd "$srcdir/$_ddir"
38   make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
41 # Local Variables:
42 # mode: shell-script
43 # sh-basic-offset: 2
44 # End:
45 # vim:set ts=2 sw=2 et: