archrelease: copy trunk to extra-x86_64
[arch-packages.git] / compface / trunk / PKGBUILD
blobb24d0ca7c060c43b87f5908538fcd3b9fe2b72d0
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: simo <simo@archlinux.org> 
3 # Contributor: Manolis Tzanidakis
5 pkgname=compface
6 pkgver=1.5.2
7 pkgrel=9
8 pkgdesc="Utils & libs to convert from/to X-Face format."
9 arch=('x86_64')
10 url="http://ftp.xemacs.org/pub/xemacs/aux/"
11 license=('custom')
12 depends=('glibc')
13 source=(#$url/$pkgname-$pkgver.tar.gz
14         http://mirrors.ibiblio.org/xemacs/aux/$pkgname-$pkgver.tar.gz
15         compface-1.5.2-build.patch
16         LICENSE)
17 md5sums=('62f4f79c0861ad292ba3cf77b4c48319'
18          '25874b31f97a53f66ceed54f6b422515'
19          '27a0d5a4d695e68b4d3eebe17db77189')
21 prepare() {
22   cd $pkgname-$pkgver
23   patch -Np0 -i ${srcdir}/compface-1.5.2-build.patch
26 build() {
27   cd $pkgname-$pkgver
28   CFLAGS="$CFLAGS -fPIC"
29   ./configure --prefix=/usr --mandir=/usr/share/man
30   make
33 package() {
34   cd $pkgname-$pkgver
35   make DESTDIR="$pkgdir" STRIP=/bin/true install
37   install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE