archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kwayland / trunk / PKGBUILD
blob434c817903f656fb81c0044220ea4bd4b1247b5a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kwayland
6 pkgver=5.91.0
7 pkgrel=1
8 pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries'
9 arch=(x86_64)
10 url='https://www.kde.org'
11 license=(LGPL)
12 depends=(qt5-wayland)
13 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc wayland-protocols plasma-wayland-protocols)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('3efdfa6539fb0c053092ef5f178d0ea776a93a35754eefb1be348dcbd46403a8'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
19 options=(debug)
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DCMAKE_INSTALL_LIBEXECDIR=lib \
24     -DBUILD_TESTING=OFF \
25     -DBUILD_QCH=ON
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build