1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=(pangomm-2.48 pangomm-2.48-docs)
8 pkgdesc="C++ bindings for Pango"
9 url="https://www.gtkmm.org/"
12 depends=(pango glibmm-2.68 cairomm-1.16)
13 makedepends=(git meson mm-common glibmm-2.68-docs cairomm-1.16-docs)
15 _commit=cd00ba55a53b71a41fb566827db8b7d7c28c36b6 # tags/2.50.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/pangomm.git#commit=$_commit")
21 git describe --tags | sed 's/-/+/g'
29 arch-meson pangomm build -D maintainer-mode=true
30 meson compile -C build
34 meson test -C build --print-errorlogs
37 package_pangomm-2.48() {
38 depends+=(libsigc-3.0.so libglibmm-2.68.so libcairomm-1.16.so)
39 provides=(libpangomm-2.48.so)
41 meson install -C build --destdir "$pkgdir"
44 mkdir -p docs/usr/share
45 mv -t docs/usr/share "$pkgdir"/usr/share/{devhelp,doc}
48 package_pangomm-2.48-docs() {
49 pkgdesc+=" (documentation)"
53 mv -t "$pkgdir" docs/*