archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-prometheus_client / trunk / PKGBUILD
blob1fa425f0a152db724bcda4598ea204f11e0346bf
1 # Maintainer: Johannes Löthberg <johannes@kyriasis.com>
3 pkgname=python-prometheus_client
4 pkgver=0.13.1
5 pkgrel=1
7 pkgdesc="Prometheus instrumentation library for Python applications"
8 url="https://github.com/prometheus/client_python"
9 arch=('any')
10 license=('APACHE')
12 depends=('python')
13 makedepends=('python-setuptools')
14 checkdepends=('python-twisted' 'python-pytest')
16 source=(client_python-$pkgver.tar.gz::https://github.com/prometheus/client_python/archive/v${pkgver}.tar.gz)
18 sha512sums=('8d5263ff00fc4797fa65a446bdab4dc3c717cc091f8cee571fdd2130febc480cc61e73e11145ac2bf9bc0eee132efc92d88a4d4facd61d515234748791a92255')
20 build() {
21   cd client_python-$pkgver
22   python setup.py build
25 check() {
26   cd client_python-$pkgver
27   # Make reproducible by not writing pyc files for test files. (rebuilderd does not run tests)
28   PYTHONDONTWRITEBYTECODE=1 python setup.py test
31 package() {
32   cd client_python-$pkgver
33   python setup.py install --root="$pkgdir" --skip-build --optimize=1