archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-rdflib / trunk / PKGBUILD
blob747acfa58d6eb1ce161a98de2f22bf5c3c2a27f3
1 # Maintainer:
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Leif Warner <abimelech@gmail.com>
5 pkgname=python-rdflib
6 pkgver=6.1.1
7 pkgrel=1
8 pkgdesc="A Python library for working with RDF, a simple yet powerful language for representing information"
9 arch=('any')
10 url="http://rdflib.net/"
11 license=('BSD')
12 depends=('python-isodate' 'python-pyparsing')
13 optdepends=('python-html5lib: for html support'
14             'python-requests: for sparql support')
15 makedepends=('python-setuptools')
16 checkdepends=('python-pytest' 'python-six' 'python-html5lib' 'python-requests' 'python-networkx'
17               'python-doctest-ignore-unicode')
18 source=(rdflib-$pkgver.tar.gz::https://github.com/RDFLib/rdflib/tarball/$pkgver)
19 sha512sums=('2381ff71b09ec31a5802fac62ec161d89ec25f695981821541d0b959f803442442e3f6eac14a60722012536e02979cc53d55be42d931024c4d09606e75575163')
21 build() {
22   cd RDFLib-rdflib-*
23   python setup.py build
26 check() {
27   cd RDFLib-rdflib-*
28   pytest
31 package() {
32   cd RDFLib-rdflib-*
33   python setup.py install --root="$pkgdir" --optimize=1
34   install -Dm644  LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"