1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
4 pkgname=('zsh' 'zsh-doc')
8 url='https://www.zsh.org/'
10 makedepends=('pcre' 'libcap' 'gdbm')
11 source=("https://www.zsh.org/pub/zsh-${pkgver}"{,-doc}".tar.xz"{,.asc}
13 sha512sums=('f54a5a47ed15d134902613f6169c985680afc45a67538505e11b66b348fcb367145e9b8ae2d9eac185e07ef5f97254b85df01ba97294002a8c036fd02ed5e76d'
15 '0d8ca4c54c10e8a471ba7d53f1371ee057f7df4b710fc01194833f29a61b5465133432b891b0b891b6cc5235a928a783bf99f39c67314e29e3d161ca5abf3219'
17 'b287e00d8de4dc4cfb1c52bb2aef1d4b191de3512baad4c91dc81e78ddc3e5bb07297f43924b022ac44ff401a348d8a9fa366e19ddc8ea1ea72df311f5ed0034')
18 validpgpkeys=('F7B2754C7DE2830914661F0EA71D9A9D4BDB27B3'
19 'E96646BE08C0AF0AA0F90788A5FEEE3AC7937444'
20 '7CA7ECAAF06216B90F894146ACF8146CAE8CBBC4')
23 cd "${srcdir}/${pkgbase}-${pkgver}"
25 # Set correct keymap path
26 sed -i 's#/usr/share/keymaps#/usr/share/kbd/keymaps#g' Completion/Unix/Command/_loadkeys
29 sed -i 's#/usr/share/misc/usb.ids#/usr/share/hwdata/usb.ids#g' Completion/Linux/Command/_lsusb
31 # Remove unneeded and conflicting completion scripts
32 for _fpath in AIX BSD Cygwin Darwin Debian Mandriva openSUSE Redhat Solaris; do
33 rm -rf Completion/$_fpath
34 sed "s#\s*Completion/$_fpath/\*/\*##g" -i Src/Zle/complete.mdd
36 rm Completion/Linux/Command/_pkgtool
40 cd "${srcdir}/${pkgbase}-${pkgver}"
42 ./configure --prefix=/usr \
43 --docdir=/usr/share/doc/zsh \
44 --htmldir=/usr/share/doc/zsh/html \
45 --enable-etcdir=/etc/zsh \
46 --enable-zshenv=/etc/zsh/zshenv \
47 --enable-zlogin=/etc/zsh/zlogin \
48 --enable-zlogout=/etc/zsh/zlogout \
49 --enable-zprofile=/etc/zsh/zprofile \
50 --enable-zshrc=/etc/zsh/zshrc \
51 --enable-maildir-support \
52 --with-term-lib='ncursesw' \
54 --enable-function-subdirs \
55 --enable-fndir=/usr/share/zsh/functions \
56 --enable-scriptdir=/usr/share/zsh/scripts \
60 --enable-zsh-secure-free
65 cd "${srcdir}/${pkgbase}-${pkgver}"
66 HOME="${srcdir}" make check
70 pkgdesc='A very advanced and programmable command interpreter (shell) for UNIX'
71 depends=('pcre' 'libcap' 'gdbm')
72 backup=('etc/zsh/zprofile')
75 cd "${srcdir}/${pkgbase}-${pkgver}"
76 make DESTDIR="${pkgdir}/" install
77 install -D -m644 "${srcdir}/zprofile" "${pkgdir}/etc/zsh/zprofile"
78 install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
82 pkgdesc='Info, HTML and PDF format of the ZSH documentation'
84 cd "${srcdir}/${pkgbase}-${pkgver}"
85 make DESTDIR="${pkgdir}/" install.info install.html
86 install -D -m644 Doc/zsh.pdf "${pkgdir}/usr/share/doc/zsh/zsh.pdf"
87 install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"