OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-mines / trunk / PKGBUILD
blobd84fdbbae32559d29018d89380e9c97c62c2ea87
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-mines
5 pkgver=40.1
6 pkgrel=1
7 pkgdesc="Clear hidden mines from a minefield"
8 url="https://wiki.gnome.org/Apps/Mines"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(yelp-tools appstream-glib vala git meson)
13 groups=(gnome-extra)
14 _commit=c7a2abc8a62a2d313959db76df3a811209409dc9  # tags/40.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-mines.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"