1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Link Dupont <link@subpop.net>
6 pkgname=(devhelp devhelp-docs)
7 pkgver=41.2+r48+g14272cae
9 pkgdesc="API documentation browser for GNOME"
10 url="https://wiki.gnome.org/Apps/Devhelp"
14 makedepends=(git appstream-glib gobject-introspection meson yelp-tools
17 _commit=14272caec5175cacba4a044f4cacd591c0db8351 # main
18 source=("git+https://gitlab.gnome.org/GNOME/devhelp.git#commit=$_commit")
23 git describe --tags | sed 's/\.alpha/alpha/;s/[^-]*-g/r&/;s/-/+/g'
31 arch-meson devhelp build \
33 -D plugin_emacs=true \
34 -D plugin_gedit=true \
36 meson compile -C build
40 meson test -C build --print-errorlogs
46 meson install -C build --destdir "$pkgdir"
49 mkdir -p docs/usr/share
50 mv -t docs/usr/share "$pkgdir"/usr/share/doc
53 package_devhelp-docs() {
54 pkgdesc+=" (documentation)"
57 mv -t "$pkgdir" docs/*