upgpkg: sbcl 2.2.11-1
[arch-packages.git] / gnome-characters / repos / extra-x86_64 / PKGBUILD
blob7066e71e4b98e249803bd67b61a5e21b7fb2c841
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-characters
5 pkgver=43.0
6 pkgrel=1
7 pkgdesc="A character map application"
8 arch=(x86_64)
9 url="https://gitlab.gnome.org/GNOME/gnome-characters"
10 license=(GPL2)
11 depends=(gjs gtk4 libunistring gnome-desktop-4 emoji-font libadwaita)
12 makedepends=(meson gobject-introspection appstream-glib git gperf)
13 groups=(gnome)
14 options=(debug)
15 _commit=661a3561e3d3130c8b47b4e9610e5d960d9db8af  # tags/43.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-characters.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"
41 # vim:set sw=2 sts=-1 et: