1 # Maintainer : Tom Gundersen <teg@jklm.no>
2 # Maintainer : Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
8 pkgdesc="A library to handle Apple Property List format whereas it's binary or XML"
9 url="https://libimobiledevice.org/"
11 license=('GPL2' 'LGPL2.1')
13 makedepends=('python' 'cython' 'autoconf-archive' 'git' 'python-setuptools')
14 options=('!makeflags')
15 _commit=c5a30e9267068436a75b5d00fcbf95cb9c1f4dcd
16 source=("git+https://github.com/libimobiledevice/libplist#commit=$_commit")
21 git describe --tags | sed 's/-/+/g'
26 # Update ac_python_devel.m4 to newer ax_python_devel.m4
27 git cherry-pick -n 42bb64ba96
28 NOCONFIGURE=1 ./autogen.sh
33 ./configure --prefix=/usr
34 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
45 make DESTDIR="$pkgdir" install
46 install -D -m644 cython/plist.pxd "${pkgdir}"/usr/include/plist/cython/plist.pxd