- prusaslicer: bitrotten ebuild
[booboo.git] / dev-haskell / retry / retry-9999.ebuild
blobbc1243b6fb8ae710a06d943f7b262223d6fc60d3
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=6
7 # ebuild generated by hackport 0.5.9999
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal git-r3
12 DESCRIPTION="Retry combinators for monadic actions that may fail"
13 HOMEPAGE="https://github.com/Soostone/retry"
14 EGIT_REPO_URI="https://github.com/Soostone/retry"
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS=""
19 IUSE=""
21 RDEPEND="dev-haskell/data-default-class:=[profile?]
22 >=dev-haskell/exceptions-0.5:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
23 >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.2:=[profile?]
24 <dev-haskell/transformers-0.6:=[profile?]
25 >=dev-lang/ghc-7.6.1:=
27 DEPEND="${RDEPEND}
28 >=dev-haskell/cabal-1.16.0
29 test? ( >=dev-haskell/hspec-1.9
30 >=dev-haskell/hunit-1.2.5.2 <dev-haskell/hunit-1.4
31 dev-haskell/mtl
32 >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9
33 dev-haskell/stm )