glib-networking: bump to version 2.48.1
[buildroot-gz.git] / package / libao / libao.mk
bloba314c08d1783bb50fd13f0053f830c8f40e58d0c
1 ################################################################################
3 # libao
5 ################################################################################
7 LIBAO_VERSION = 1.2.0
8 LIBAO_SITE = http://downloads.xiph.org/releases/ao
9 LIBAO_DEPENDENCIES = host-pkgconf
10 LIBAO_INSTALL_STAGING = YES
11 LIBAO_LICENSE = GPLv2+
12 LIBAO_LICENSE_FILES = COPYING
13 LIBAO_CONF_OPTS = \
14 --disable-esd \
15 --disable-wmm \
16 --disable-arts \
17 --disable-nas \
18 --disable-pulse \
19 --disable-broken-oss
21 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
22 LIBAO_DEPENDENCIES += alsa-lib
23 LIBAO_CONF_OPTS += --enable-alsa --enable-alsa-mmap
25 # Remove the OSS plugin if ALSA is enabled, as libao will prefer ALSA anyway
26 define LIBAO_REMOVE_OSS_PLUGIN
27 rm -f $(TARGET_DIR)/usr/lib/ao/plugins-4/liboss.so
28 endef
29 LIBAO_POST_INSTALL_TARGET_HOOKS += LIBAO_REMOVE_OSS_PLUGIN
30 else
31 LIBAO_CONF_OPTS += --disable-alsa
32 endif
34 $(eval $(autotools-package))