1 ################################################################################
5 ################################################################################
7 UPMPDCLI_VERSION
= 1.1.3
8 UPMPDCLI_SITE
= http
://www.lesbonscomptes.com
/upmpdcli
/downloads
9 UPMPDCLI_LICENSE
= GPLv2
+
10 UPMPDCLI_LICENSE_FILES
= COPYING
11 UPMPDCLI_DEPENDENCIES
= libmpdclient libupnpp
13 ifeq ($(BR2_STATIC_LIBS
),y
)
14 # Upmpdcli forgets to take the dependencies of libupnpp into
15 # consideration, breaking static linking, so help it.
16 # Libupnpp unfortunately doesn't provide a .pc file, so manually
17 # handle the dependencies here.
18 # The build system doesn't expand LIBS from the configure step, so
19 # manually pass it to make.
20 UPMPDCLI_DEPENDENCIES
+= host-pkgconf
21 UPMPDCLI_MAKE_OPTS
= \
22 LIBS
="`$(PKG_CONFIG_HOST_BINARY) --libs expat libcurl libupnp`"
25 # Upmpdcli only runs if user upmpdcli exists
27 upmpdcli
-1 upmpdcli
-1 * - - - Upmpdcli MPD UPnP Renderer Front-End
30 define UPMPDCLI_INSTALL_INIT_SYSV
31 $(INSTALL
) -D
-m
0755 package
/upmpdcli
/S99upmpdcli
$(TARGET_DIR
)/etc
/init.d
/S99upmpdcli
34 define UPMPDCLI_INSTALL_INIT_SYSTEMD
35 $(INSTALL
) -D
-m
644 $(@D
)/systemd
/upmpdcli.service \
36 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/upmpdcli.service
37 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
38 ln
-sf ..
/..
/..
/..
/usr
/lib
/systemd
/system
/upmpdcli.service \
39 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/upmpdcli.service
42 define UPMPDCLI_INSTALL_CONF_FILE
43 $(INSTALL
) -D
-m
0755 $(@D
)/src
/upmpdcli.conf-dist
$(TARGET_DIR
)/etc
/upmpdcli.conf
46 UPMPDCLI_POST_INSTALL_TARGET_HOOKS
+= UPMPDCLI_INSTALL_CONF_FILE
48 $(eval
$(autotools-package
))