package/dhcp/S80dhcp-server: allow empty INTERFACES
[buildroot-gz.git] / package / libxslt / libxslt.mk
blob2e5cc14b54239c0da89d9df306417552237a2885
1 ################################################################################
3 # libxslt
5 ################################################################################
7 LIBXSLT_VERSION = 1.1.28
8 LIBXSLT_SITE = ftp://xmlsoft.org/libxslt
9 LIBXSLT_INSTALL_STAGING = YES
10 LIBXSLT_LICENSE = MIT
11 LIBXSLT_LICENSE_FILES = COPYING
13 LIBXSLT_CONF_OPTS = \
14 --with-gnu-ld \
15 --without-debug \
16 --without-python \
17 --with-libxml-prefix=$(STAGING_DIR)/usr/
18 LIBXSLT_CONFIG_SCRIPTS = xslt-config
19 LIBXSLT_DEPENDENCIES = libxml2
21 # If we have enabled libgcrypt then use it, else disable crypto support.
22 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
23 LIBXSLT_DEPENDENCIES += libgcrypt
24 LIBXSLT_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
25 else
26 LIBXSLT_CONF_OPTS += --without-crypto
27 endif
29 HOST_LIBXSLT_CONF_OPTS = --without-debug --without-python --without-crypto
31 HOST_LIBXSLT_DEPENDENCIES = host-libxml2
33 $(eval $(autotools-package))
34 $(eval $(host-autotools-package))