1 ################################################################################
5 ################################################################################
7 NTP_VERSION_MAJOR
= 4.2
8 NTP_VERSION
= $(NTP_VERSION_MAJOR
).8p4
9 NTP_SITE
= http
://www.eecis.udel.edu
/~ntp
/ntp_spool
/ntp4
/ntp-
$(NTP_VERSION_MAJOR
)
10 NTP_DEPENDENCIES
= host-pkgconf libevent
$(if
$(BR2_PACKAGE_BUSYBOX
),busybox
)
11 NTP_LICENSE
= ntp license
12 NTP_LICENSE_FILES
= COPYRIGHT
13 NTP_CONF_ENV
= ac_cv_lib_md5_MD5Init
=no
16 --program-transform-name
=s
,,, \
18 --with-yielding-select
=yes \
19 --disable-local-libevent
20 # 0002-ntp-syscalls-fallback.patch
23 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
24 NTP_CONF_OPTS
+= --with-crypto
25 NTP_DEPENDENCIES
+= openssl
27 NTP_CONF_OPTS
+= --without-crypto
--disable-openssl-random
30 ifeq ($(BR2_PACKAGE_NTP_NTPSNMPD
),y
)
32 --with-net-snmp-config
=$(STAGING_DIR
)/usr
/bin
/net-snmp-config
33 NTP_DEPENDENCIES
+= netsnmp
35 NTP_CONF_OPTS
+= --without-ntpsnmpd
38 ifeq ($(BR2_PACKAGE_NTP_NTPD_ATOM_PPS
),y
)
39 NTP_CONF_OPTS
+= --enable-ATOM
40 NTP_DEPENDENCIES
+= pps-tools
42 NTP_CONF_OPTS
+= --disable-ATOM
45 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTP_KEYGEN
) += util
/ntp-keygen
46 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTP_WAIT
) += scripts
/ntp-wait
/ntp-wait
47 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTPDATE
) += ntpdate
/ntpdate
48 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTPDC
) += ntpdc
/ntpdc
49 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTPQ
) += ntpq
/ntpq
50 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTPSNMPD
) += ntpsnmpd
/ntpsnmpd
51 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTPTIME
) += util
/ntptime
52 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_NTPTRACE
) += scripts
/ntptrace
/ntptrace
53 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_SNTP
) += sntp
/sntp
54 NTP_INSTALL_FILES_
$(BR2_PACKAGE_NTP_TICKADJ
) += util
/tickadj
56 define NTP_INSTALL_TARGET_CMDS
57 $(if
$(BR2_PACKAGE_NTP_NTPD
), install -m
755 $(@D
)/ntpd
/ntpd
$(TARGET_DIR
)/usr
/sbin
/ntpd
)
58 test -z
"$(NTP_INSTALL_FILES_y)" ||
install -m
755 $(addprefix $(@D
)/,$(NTP_INSTALL_FILES_y
)) $(TARGET_DIR
)/usr
/bin
/
59 $(INSTALL
) -m
644 package
/ntp
/ntpd.etc.conf
$(TARGET_DIR
)/etc
/ntp.conf
62 ifeq ($(BR2_PACKAGE_NTP_NTPD
),y
)
63 define NTP_INSTALL_INIT_SYSV
64 $(INSTALL
) -D
-m
755 package
/ntp
/S49ntp
$(TARGET_DIR
)/etc
/init.d
/S49ntp
67 define NTP_INSTALL_INIT_SYSTEMD
68 $(INSTALL
) -D
-m
644 package
/ntp
/ntpd.service
$(TARGET_DIR
)/usr
/lib
/systemd
/system
/ntpd.service
69 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
70 ln
-fs ..
/..
/..
/..
/usr
/lib
/systemd
/system
/ntpd.service \
71 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/ntpd.service
75 $(eval
$(autotools-package
))