1 ################################################################################
5 ################################################################################
7 # git commit sha1 is used as there is no release tag with autotools support yet
8 SPI_TOOLS_VERSION
= cc6a41fdcec60610703ba6db488c621c64952898
9 SPI_TOOLS_SITE
= $(call github
,cpb-
,spi-tools
,$(SPI_TOOLS_VERSION
))
10 # autoreconf must be run as specified in package documentation
11 SPI_TOOLS_AUTORECONF
= YES
12 SPI_TOOLS_LICENSE
= GPLv2
13 SPI_TOOLS_LICENSE_FILES
= LICENSE
15 # Package attempts to use git to obtain version, that fails within Buildroot.
16 # To avoid it, set the GIT_VERSION variable to the Buildroot package version.
17 define SPI_TOOLS_SET_VERSION
18 $(SED
) "s/^\(GIT_VERSION:=\).*/\1$(SPI_TOOLS_VERSION)/" \
22 SPI_TOOLS_POST_PATCH_HOOKS
= SPI_TOOLS_SET_VERSION
24 $(eval
$(autotools-package
))