1 ################################################################################
5 ################################################################################
7 GTK2_ENGINES_VERSION_MAJOR
= 2.20
8 GTK2_ENGINES_VERSION
= $(GTK2_ENGINES_VERSION_MAJOR
).2
9 GTK2_ENGINES_SOURCE
= gtk-engines-
$(GTK2_ENGINES_VERSION
).
tar.bz2
10 GTK2_ENGINES_SITE
= http
://ftp.gnome.org
/pub
/GNOME
/sources
/gtk-engines
/$(GTK2_ENGINES_VERSION_MAJOR
)
11 GTK2_ENGINES_DEPENDENCIES
= libgtk2 host-intltool
12 GTK2_ENGINES_LICENSE
= LGPLv2.1
+
13 GTK2_ENGINES_LICENSE_FILES
= COPYING
15 GTK2_ENGINES_CONF_ENV
= \
16 ac_cv_func_posix_getpwuid_r
=yes \
17 glib_cv_stack_grows
=no \
19 ac_cv_func_strtod
=yes \
20 ac_fsusage_space
=yes \
21 fu_cv_sys_stat_statfs2_bsize
=yes \
22 ac_cv_func_closedir_void
=no \
23 ac_cv_func_getloadavg
=no \
24 ac_cv_lib_util_getloadavg
=no \
25 ac_cv_lib_getloadavg_getloadavg
=no \
26 ac_cv_func_getgroups
=yes \
27 ac_cv_func_getgroups_works
=yes \
28 ac_cv_func_chown_works
=yes \
29 ac_cv_have_decl_euidaccess
=no \
30 ac_cv_func_euidaccess
=no \
31 ac_cv_have_decl_strnlen
=yes \
32 ac_cv_func_strnlen_working
=yes \
33 ac_cv_func_lstat_dereferences_slashed_symlink
=yes \
34 ac_cv_func_lstat_empty_string_bug
=no \
35 ac_cv_func_stat_empty_string_bug
=no \
36 vb_cv_func_rename_trailing_slash_bug
=no \
37 ac_cv_have_decl_nanosleep
=yes \
38 jm_cv_func_nanosleep_works
=yes \
39 gl_cv_func_working_utimes
=yes \
40 ac_cv_func_utime_null
=yes \
41 ac_cv_have_decl_strerror_r
=yes \
42 ac_cv_func_strerror_r_char_p
=no \
43 jm_cv_func_svid_putenv
=yes \
44 ac_cv_func_getcwd_null
=yes \
45 ac_cv_func_getdelim
=yes \
46 ac_cv_func_mkstemp
=yes \
47 utils_cv_func_mkstemp_limitations
=no \
48 utils_cv_func_mkdir_trailing_slash_bug
=no \
49 jm_cv_func_gettimeofday_clobber
=no \
50 gl_cv_func_working_readdir
=yes \
51 jm_ac_cv_func_link_follows_symlink
=no \
52 utils_cv_localtime_cache
=no \
53 ac_cv_struct_st_mtim_nsec
=no \
54 gl_cv_func_tzset_clobber
=no \
55 gl_cv_func_getcwd_null
=yes \
56 gl_cv_func_getcwd_path_max
=yes \
57 ac_cv_func_fnmatch_gnu
=yes \
58 am_getline_needs_run_time_check
=no \
59 am_cv_func_working_getline
=yes \
60 gl_cv_func_mkdir_trailing_slash_bug
=no \
61 gl_cv_func_mkstemp_limitations
=no \
62 ac_cv_func_working_mktime
=yes \
63 jm_cv_func_working_re_compile_pattern
=yes \
64 ac_use_included_regex
=no \
66 ac_cv_path_CUPS_CONFIG
=no
68 GTK2_ENGINES_CONF_OPTS
= \
70 --x-includes
=$(STAGING_DIR
)/usr
/include/X11 \
71 --x-libraries
=$(STAGING_DIR
)/usr
/lib \
73 --enable-explicit-deps
=no \
77 --disable-industrial \
84 --disable-development \
88 $(eval
$(autotools-package
))