1 ################################################################################
5 ################################################################################
7 NETPLUG_VERSION
= 1.2.9.2
8 NETPLUG_SOURCE
= netplug-
$(NETPLUG_VERSION
).
tar.bz2
9 NETPLUG_SITE
= http
://www.red-bean.com
/~bos
/netplug
10 NETPLUG_LICENSE
= GPLv2
11 NETPLUG_LICENSE_FILES
= COPYING
13 define NETPLUG_BUILD_CMDS
14 $(TARGET_MAKE_ENV
) $(MAKE
) $(TARGET_CONFIGURE_OPTS
) -C
$(@D
)
17 define NETPLUG_INSTALL_TARGET_CMDS
18 $(TARGET_MAKE_ENV
) $(MAKE
) DESTDIR
=$(TARGET_DIR
) -C
$(@D
) install
21 define NETPLUG_INSTALL_INIT_SYSV
22 $(INSTALL
) -m
0755 -D package
/netplug
/S29netplug \
23 $(TARGET_DIR
)/etc
/init.d
/S29netplug
26 define NETPLUG_INSTALL_INIT_SYSTEMD
27 $(INSTALL
) -D
-m
644 package
/netplug
/netplug.service \
28 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/netplug.service
29 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
30 ln
-sf ..
/..
/..
/..
/usr
/lib
/systemd
/system
/netplug.service \
31 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/netplug.service
34 $(eval
$(generic-package
))