open-plc-utils: new package
[buildroot-gz.git] / package / vnstat / vnstat.mk
blobe0a64d57084cd1d81a6f2098108d2cf55c776e85
1 ################################################################################
3 # vnstat
5 ################################################################################
7 VNSTAT_VERSION = 1.12
8 VNSTAT_SITE = http://humdi.net/vnstat
9 VNSTAT_LICENSE = GPLv2
10 VNSTAT_LICENSE_FILES = COPYING
12 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
13 VNSTAT_DEPENDENCIES = gd
14 VNSTAT_GD_MAKE_OPT = all
15 define VNSTAT_INSTALL_VNSTATI_CMDS
16 $(INSTALL) -D -m 0755 $(@D)/src/vnstati $(TARGET_DIR)/usr/bin/vnstati
17 endef
18 endif
20 define VNSTAT_BUILD_CMDS
21 $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) $(VNSTAT_GD_MAKE_OPT)
22 endef
24 define VNSTAT_INSTALL_TARGET_CMDS
25 $(INSTALL) -D -m 0755 $(@D)/src/vnstat $(TARGET_DIR)/usr/bin/vnstat
26 $(INSTALL) -D -m 0755 $(@D)/src/vnstatd $(TARGET_DIR)/usr/sbin/vnstatd
27 $(VNSTAT_INSTALL_VNSTATI_CMDS)
28 endef
30 $(eval $(generic-package))