1 ################################################################################
5 ################################################################################
8 USHARE_SOURCE
= ushare-
$(USHARE_VERSION
).
tar.bz2
9 USHARE_SITE
= http
://ushare.geexbox.org
/releases
10 USHARE_DEPENDENCIES
= host-pkgconf libupnp
11 USHARE_LICENSE
= GPLv2
+
12 USHARE_LICENSE_FILES
= COPYING
14 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE
),y
)
15 USHARE_DEPENDENCIES
+= gettext
16 USHARE_LDFLAGS
+= -lintl
19 define USHARE_CONFIGURE_CMDS
21 $(TARGET_CONFIGURE_OPTS
) \
22 .
/configure
--prefix=/usr
$(DISABLE_NLS
) --cross-compile \
23 --cross-prefix
="$(TARGET_CROSS)" --sysconfdir
=/etc \
28 define USHARE_BUILD_CMDS
29 $(MAKE
) LDFLAGS
="$(TARGET_LDFLAGS) $(USHARE_LDFLAGS)" -C
$(@D
)
32 define USHARE_INSTALL_TARGET_CMDS
33 $(MAKE
) -C
$(@D
) DESTDIR
=$(TARGET_DIR
) install
34 rm -f
$(TARGET_DIR
)/etc
/init.d
/ushare
37 # Even though configure is called it's not autoconf
38 $(eval
$(generic-package
))