1 ################################################################################
5 ################################################################################
7 NET_TOOLS_VERSION
= 3f170bff115303e92319791cbd56371e33dcbf6d
8 NET_TOOLS_SITE
= git
://git.code.sf.net
/p
/net-tools
/code
9 NET_TOOLS_DEPENDENCIES
= $(if
$(BR2_NEEDS_GETTEXT_IF_LOCALE
),gettext
)
10 NET_TOOLS_LICENSE
= GPLv2
+
11 NET_TOOLS_LICENSE_FILES
= COPYING
13 # Install after busybox for the full-blown versions
14 ifeq ($(BR2_PACKAGE_BUSYBOX
),y
)
15 NET_TOOLS_DEPENDENCIES
+= busybox
18 define NET_TOOLS_CONFIGURE_CMDS
19 (cd
$(@D
); yes
"" | .
/configure.sh config.in
)
22 # Enable I18N when appropiate
23 ifeq ($(BR2_ENABLE_LOCALE
),y
)
24 define NET_TOOLS_ENABLE_I18N
25 $(SED
) 's:I18N 0:I18N 1:' $(@D
)/config.h
30 define NET_TOOLS_ENABLE_IPV6
31 $(SED
) 's:_AFINET6 0:_AFINET6 1:' $(@D
)/config.h
34 NET_TOOLS_POST_CONFIGURE_HOOKS
+= NET_TOOLS_ENABLE_I18N NET_TOOLS_ENABLE_IPV6
36 define NET_TOOLS_BUILD_CMDS
37 $(TARGET_CONFIGURE_OPTS
) \
38 LIBS
="$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)" \
42 # install renames conflicting binaries, update does not
43 # ifconfig & route reside in /sbin for busybox
44 define NET_TOOLS_INSTALL_TARGET_CMDS
45 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) DESTDIR
=$(TARGET_DIR
) update
46 mv
-f
$(TARGET_DIR
)/bin
/ifconfig
$(TARGET_DIR
)/sbin
/ifconfig
47 mv
-f
$(TARGET_DIR
)/bin
/route
$(TARGET_DIR
)/sbin
/route
50 $(eval
$(generic-package
))