1 ################################################################################
5 ################################################################################
7 SMSTOOLS3_VERSION
= 3.1.15
8 SMSTOOLS3_SITE
= http
://smstools3.kekekasvi.com
/packages
9 SMSTOOLS3_LICENSE
= GPLv2
+
10 SMSTOOLS3_LICENSE_FILES
= doc
/license.html LICENSE
12 SMSTOOLS3_CFLAGS
= $(TARGET_CFLAGS
)
13 SMSTOOLS3_CFLAGS
+= -D NUMBER_OF_MODEMS
=$(BR2_PACKAGE_SMSTOOLS3_NB_MODEMS
)
14 SMSTOOLS3_CFLAGS
+= -D NOSTATS
16 define SMSTOOLS3_BUILD_CMDS
17 $(TARGET_MAKE_ENV
) $(MAKE
) CC
="$(TARGET_CC)" CFLAGS
="$(SMSTOOLS3_CFLAGS)" -C
$(@D
)
20 define SMSTOOLS3_INSTALL_INIT_SYSV
21 $(INSTALL
) -m
0755 -D package
/smstools3
/S50smsd \
22 $(TARGET_DIR
)/etc
/init.d
/S50smsd
25 define SMSTOOLS3_INSTALL_TARGET_CMDS
26 $(INSTALL
) -m
0755 -D
$(@D
)/src
/smsd \
27 $(TARGET_DIR
)/usr
/bin
/smsd
28 $(INSTALL
) -m
0755 -D
$(@D
)/scripts
/sendsms \
29 $(TARGET_DIR
)/usr
/bin
/sendsms
30 $(INSTALL
) -m
0644 -D
$(@D
)/examples
/smsd.conf.easy \
31 $(TARGET_DIR
)/etc
/smsd.conf
34 $(eval
$(generic-package
))