1 ################################################################################
5 ################################################################################
7 PYTHON_LXML_VERSION
= 3.6.0
8 PYTHON_LXML_SITE
= http
://lxml.de
/files
9 PYTHON_LXML_SOURCE
= lxml-
$(PYTHON_LXML_VERSION
).tgz
11 # Not including the GPL, because it is used only for the test scripts.
12 PYTHON_LXML_LICENSE
= BSD-3c
, Others
13 PYTHON_LXML_LICENSE_FILES
= \
15 doc
/licenses
/BSD.txt \
16 doc
/licenses
/elementtree.txt \
17 src
/lxml
/isoschematron
/resources
/rng
/iso-schematron.rng
19 # python-lxml can use either setuptools, or distutils as a fallback.
20 # So, we use setuptools.
21 PYTHON_LXML_SETUP_TYPE
= setuptools
23 PYTHON_LXML_DEPENDENCIES
= libxml2 libxslt zlib
25 # python-lxml needs these scripts in order to properly detect libxml2 and
26 # libxslt compiler and linker flags
27 PYTHON_LXML_BUILD_OPTS
= \
28 --with-xslt-config
=$(STAGING_DIR
)/usr
/bin
/xslt-config \
29 --with-xml2-config
=$(STAGING_DIR
)/usr
/bin
/xml2-config
31 $(eval
$(python-package
))