hplip: needs dynamic library
[buildroot-gz.git] / package / wvstreams / wvstreams.mk
blob4d344e28340f34daa409a9e6e1c13726921ebcd5
1 ################################################################################
3 # wvstreams
5 ################################################################################
7 WVSTREAMS_VERSION = 4.6.1
8 WVSTREAMS_SITE = http://wvstreams.googlecode.com/files
9 WVSTREAMS_DEPENDENCIES = openssl zlib host-pkgconf
10 WVSTREAMS_INSTALL_STAGING = YES
12 WVSTREAMS_LICENSE = LGPLv2+
13 WVSTREAMS_LICENSE_FILES = LICENSE
15 # N.B. parallel make fails
16 WVSTREAMS_MAKE = $(MAKE1)
18 # Needed to work around problem with wvassert.h
19 WVSTREAMS_CONF_OPTS += CPPFLAGS=-DNDEBUG
21 WVSTREAMS_CONF_OPTS += \
22 --with-openssl \
23 --with-zlib \
24 --without-pam \
25 --disable-warnings \
26 --without-tcl
28 # needed for openssl detection when statically linking (as ssl needs lz)
29 WVSTREAMS_CONF_ENV += LIBS=-lz
31 ifneq ($(BR2_STATIC_LIBS),y)
32 WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
33 endif
35 # wvstreams uses argp.h which can be provided by the argp-standalone
36 # package
37 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
38 WVSTREAMS_DEPENDENCIES += argp-standalone
39 endif
41 ifeq ($(BR2_PACKAGE_DBUS),y)
42 WVSTREAMS_DEPENDENCIES += dbus
43 WVSTREAMS_CONF_OPTS += --with-dbus
44 else
45 WVSTREAMS_CONF_OPTS += --without-dbus
46 endif
48 ifeq ($(BR2_PACKAGE_QT),y)
49 WVSTREAMS_DEPENDENCIES += qt
50 WVSTREAMS_CONF_OPTS += --with-qt
51 else
52 WVSTREAMS_CONF_OPTS += --without-qt
53 endif
55 ifeq ($(BR2_PACKAGE_VALGRIND),y)
56 WVSTREAMS_DEPENDENCIES += valgrind
57 WVSTREAMS_CONF_OPTS += --with-valgrind
58 else
59 WVSTREAMS_CONF_OPTS += --without-valgrind
60 endif
62 $(eval $(autotools-package))