1 ################################################################################
5 ################################################################################
7 OPENNTPD_VERSION
= 5.7p4
8 OPENNTPD_SITE
= http
://ftp.openbsd.org
/pub
/OpenBSD
/OpenNTPD
9 OPENNTPD_LICENSE
= MIT-like
, BSD-2c
, BSD-3c
10 OPENNTPD_LICENSE_FILES
= COPYING
12 # openntpd uses pthread functions for arc4random emulation but forgets
14 OPENNTPD_CONF_ENV
+= CFLAGS
="$(TARGET_CFLAGS) -pthread"
16 define OPENNTPD_INSTALL_INIT_SYSTEMD
17 $(INSTALL
) -D
-m
0644 package
/openntpd
/ntpd.service \
18 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/ntpd.service
19 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
20 ln
-fs ..
/..
/..
/..
/usr
/lib
/systemd
/system
/ntpd.service \
21 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/ntpd.service
24 define OPENNTPD_INSTALL_INIT_SYSV
25 $(INSTALL
) -m
0755 -D package
/openntpd
/S49ntp \
26 $(TARGET_DIR
)/etc
/init.d
/S49ntp
30 _ntp
-1 _ntp
-1 * - - - Network Time Protocol daemon
33 $(eval
$(autotools-package
))