slang: make install-static do install-pkgconfig
[buildroot-gz.git] / package / openntpd / openntpd.mk
blob40bb1bf7e09126f98048b0667dae5a6801f8c05e
1 ################################################################################
3 # openntpd
5 ################################################################################
7 OPENNTPD_VERSION = 5.7p4
8 OPENNTPD_SITE = http://ftp.openbsd.org/pub/OpenBSD/OpenNTPD
9 OPENNTPD_LICENSE = MIT-like, BSD-2c, BSD-3c
10 OPENNTPD_LICENSE_FILES = COPYING
12 # openntpd uses pthread functions for arc4random emulation but forgets
13 # to use -pthread
14 OPENNTPD_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -pthread"
16 define OPENNTPD_INSTALL_INIT_SYSTEMD
17 $(INSTALL) -D -m 0644 package/openntpd/ntpd.service \
18 $(TARGET_DIR)/usr/lib/systemd/system/ntpd.service
19 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
20 ln -fs ../../../../usr/lib/systemd/system/ntpd.service \
21 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ntpd.service
22 endef
24 define OPENNTPD_INSTALL_INIT_SYSV
25 $(INSTALL) -m 0755 -D package/openntpd/S49ntp \
26 $(TARGET_DIR)/etc/init.d/S49ntp
27 endef
29 define OPENNTPD_USERS
30 _ntp -1 _ntp -1 * - - - Network Time Protocol daemon
31 endef
33 $(eval $(autotools-package))