luaposix: bump to version 31
[buildroot-gz.git] / package / e2fsprogs / e2fsprogs.mk
blob0670c747cdaf39a5a7f9032d3ed37ab40ba539f6
1 ################################################################################
3 # e2fsprogs
5 ################################################################################
7 E2FSPROGS_VERSION = 1.42.8
8 E2FSPROGS_SITE = http://downloads.sourceforge.net/project/e2fsprogs/e2fsprogs/v$(E2FSPROGS_VERSION)
9 E2FSPROGS_LICENSE = GPLv2, libuuid BSD-3c, libss and libet MIT-like with advertising clause
10 E2FSPROGS_LICENSE_FILES = COPYING lib/uuid/COPYING lib/ss/mit-sipb-copyright.h lib/et/internal.h
12 E2FSPROGS_CONF_OPT = \
13 --disable-tls \
14 --enable-elf-shlibs \
15 $(if $(BR2_PACKAGE_E2FSPROGS_DEBUGFS),,--disable-debugfs) \
16 $(if $(BR2_PACKAGE_E2FSPROGS_E2IMAGE),,--disable-imager) \
17 $(if $(BR2_PACKAGE_E2FSPROGS_E4DEFRAG),,--disable-defrag) \
18 $(if $(BR2_PACKAGE_E2FSPROGS_RESIZE2FS),,--disable-resizer) \
19 --disable-uuidd \
20 --disable-libblkid \
21 --disable-libuuid \
22 --enable-fsck \
23 --disable-e2initrd-helper \
24 --disable-testio-debug
26 E2FSPROGS_DEPENDENCIES = host-pkgconf util-linux
28 E2FSPROGS_MAKE_OPT = \
29 LDCONFIG=true
31 define HOST_E2FSPROGS_INSTALL_CMDS
32 $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install install-libs
33 endef
34 # we don't have a host-util-linux
35 HOST_E2FSPROGS_DEPENDENCIES = host-pkgconf
37 # binaries to keep or remove
38 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_BADBLOCKS) += usr/sbin/badblocks
39 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_CHATTR) += usr/bin/chattr
40 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_DUMPE2FS) += usr/sbin/dumpe2fs
41 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_E2FREEFRAG) += usr/sbin/e2freefrag
42 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_E2FSCK) += usr/sbin/e2fsck
43 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_E2LABEL) += usr/sbin/e2label
44 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_E2UNDO) += usr/sbin/e2undo
45 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_E4DEFRAG) += usr/sbin/e4defrag
46 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_FILEFRAG) += usr/sbin/filefrag
47 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_FSCK) += usr/sbin/fsck
48 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_LOGSAVE) += usr/sbin/logsave
49 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_LSATTR) += usr/bin/lsattr
50 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_MKE2FS) += usr/sbin/mke2fs
51 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_MKLOSTFOUND) += usr/sbin/mklost+found
52 E2FSPROGS_BINTARGETS_$(BR2_PACKAGE_E2FSPROGS_UUIDGEN) += usr/bin/uuidgen
54 # files to remove
55 E2FSPROGS_TXTTARGETS_ = \
56 usr/sbin/mkfs.ext[234] \
57 usr/sbin/mkfs.ext4dev \
58 usr/sbin/fsck.ext[234] \
59 usr/sbin/fsck.ext4dev \
60 usr/sbin/findfs \
61 usr/sbin/tune2fs
63 define E2FSPROGS_TARGET_REMOVE_UNNEEDED
64 rm -f $(addprefix $(TARGET_DIR)/, $(E2FSPROGS_BINTARGETS_))
65 rm -f $(addprefix $(TARGET_DIR)/, $(E2FSPROGS_TXTTARGETS_))
66 endef
68 E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_REMOVE_UNNEEDED
70 define E2FSPROGS_TARGET_MKE2FS_SYMLINKS
71 ln -sf mke2fs $(TARGET_DIR)/usr/sbin/mkfs.ext2
72 ln -sf mke2fs $(TARGET_DIR)/usr/sbin/mkfs.ext3
73 ln -sf mke2fs $(TARGET_DIR)/usr/sbin/mkfs.ext4
74 ln -sf mke2fs $(TARGET_DIR)/usr/sbin/mkfs.ext4dev
75 endef
77 ifeq ($(BR2_PACKAGE_E2FSPROGS_MKE2FS),y)
78 E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_MKE2FS_SYMLINKS
79 endif
81 define E2FSPROGS_TARGET_E2FSCK_SYMLINKS
82 ln -sf e2fsck $(TARGET_DIR)/usr/sbin/fsck.ext2
83 ln -sf e2fsck $(TARGET_DIR)/usr/sbin/fsck.ext3
84 ln -sf e2fsck $(TARGET_DIR)/usr/sbin/fsck.ext4
85 ln -sf e2fsck $(TARGET_DIR)/usr/sbin/fsck.ext4dev
86 endef
88 ifeq ($(BR2_PACKAGE_E2FSPROGS_E2FSCK),y)
89 E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_E2FSCK_SYMLINKS
90 endif
92 define E2FSPROGS_TARGET_TUNE2FS_SYMLINK
93 ln -sf e2label $(TARGET_DIR)/usr/sbin/tune2fs
94 endef
96 ifeq ($(BR2_PACKAGE_E2FSPROGS_TUNE2FS),y)
97 E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_TUNE2FS_SYMLINK
98 endif
100 define E2FSPROGS_TARGET_FINDFS_SYMLINK
101 ln -sf e2label $(TARGET_DIR)/usr/sbin/findfs
102 endef
104 ifeq ($(BR2_PACKAGE_E2FSPROGS_FINDFS),y)
105 E2FSPROGS_POST_INSTALL_TARGET_HOOKS += E2FSPROGS_TARGET_FINDFS_SYMLINK
106 endif
108 $(eval $(autotools-package))
109 $(eval $(host-autotools-package))