sysklogd: fix build on musl
[buildroot-gz.git] / package / sdl2_ttf / sdl2_ttf.mk
blob6834d16cb21166e77e63205c75431f7cf864117e
1 ################################################################################
3 # sdl2_ttf
5 ################################################################################
7 SDL2_TTF_VERSION = 2.0.14
8 SDL2_TTF_SOURCE = SDL2_ttf-$(SDL2_TTF_VERSION).tar.gz
9 SDL2_TTF_SITE = http://www.libsdl.org/projects/SDL_ttf/release
10 SDL2_TTF_LICENSE = zlib
11 SDL2_TTF_LICENSE_FILES = COPYING.txt
12 SDL2_TTF_INSTALL_STAGING = YES
13 SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
14 SDL2_TTF_CONF_ENV = \
15 FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
17 # x-includes and x-libraries must be set for cross-compiling
18 # By default x_includes and x_libraries contains unsafe paths.
19 # (/usr/include and /usr/lib)
20 ifeq ($(BR2_PACKAGE_SDL2_X11),y)
21 SDL2_TTF_CONF_OPTS += \
22 --with-x \
23 --x-includes=$(STAGING_DIR)/usr/include \
24 --x-libraries=$(STAGING_DIR)/usr/lib
25 else
26 SDL2_TTF_CONF_OPTS += \
27 --without-x
28 endif
30 $(eval $(autotools-package))