1 ################################################################################
5 ################################################################################
7 LIBASS_VERSION
= 0.13.2
8 LIBASS_SOURCE
= libass-
$(LIBASS_VERSION
).
tar.xz
9 # Do not use the github helper here, the generated tarball is *NOT*
10 # the same as the one uploaded by upstream for the release.
11 LIBASS_SITE
= https
://github.com
/libass
/libass
/releases
/download
/$(LIBASS_VERSION
)
12 LIBASS_INSTALL_STAGING
= YES
14 LIBASS_LICENSE_FILES
= COPYING
15 LIBASS_DEPENDENCIES
= \
19 $(if
$(BR2_PACKAGE_LIBICONV
),libiconv
)
21 # configure: WARNING: Install yasm for a significantly faster libass build.
22 # only for Intel archs
23 ifeq ($(BR2_i386
)$(BR2_x86_64
),y
)
24 LIBASS_DEPENDENCIES
+= host-yasm
27 ifeq ($(BR2_PACKAGE_FONTCONFIG
),y
)
28 LIBASS_DEPENDENCIES
+= fontconfig
29 LIBASS_CONF_OPTS
+= --enable-fontconfig
31 LIBASS_CONF_OPTS
+= --disable-fontconfig
--disable-require-system-font-provider
34 ifeq ($(BR2_PACKAGE_HARFBUZZ
),y
)
35 LIBASS_DEPENDENCIES
+= harfbuzz
36 LIBASS_CONF_OPTS
+= --enable-harfbuzz
38 LIBASS_CONF_OPTS
+= --disable-harfbuzz
41 $(eval
$(autotools-package
))