odroid-mali: new package
[buildroot-gz.git] / package / qpid-proton / qpid-proton.mk
blob2e8c1d0e92d4de8af4c2f10e95f72819f74ae0ad
1 ################################################################################
3 # qpid-proton
5 ################################################################################
7 QPID_PROTON_VERSION = 0.9.1
8 QPID_PROTON_SITE = http://apache.panu.it/qpid/proton/$(QPID_PROTON_VERSION)
9 QPID_PROTON_STRIP_COMPONENTS = 2
10 QPID_PROTON_LICENSE = Apache-2.0
11 QPID_PROTON_LICENSE_FILES = LICENSE
12 QPID_PROTON_INSTALL_STAGING = YES
13 QPID_PROTON_DEPENDENCIES = \
14 host-python \
15 util-linux \
16 $(if $(BR2_PACKAGE_OPENSSL),openssl)
18 # Language bindings are enabled when host-swig tool is present in HOST_DIR.
19 # For now, disable all of them.
20 QPID_PROTON_CONF_OPTS = \
21 -DBUILD_JAVA=OFF \
22 -DBUILD_JAVASCRIPT=OFF \
23 -DBUILD_PERL=OFF \
24 -DBUILD_PHP=OFF \
25 -DBUILD_PYTHON=OFF \
26 -DBUILD_RUBY=OFF \
27 -DENABLE_VALGRIND=OFF \
28 -DENABLE_WARNING_ERROR=OFF \
29 -DPYTHON_EXECUTABLE=$(HOST_DIR)/usr/bin/python2
31 define QPID_PROTON_REMOVE_USELESS_FILES
32 rm -fr $(TARGET_DIR)/usr/share/proton-*/
33 endef
35 QPID_PROTON_POST_INSTALL_TARGET_HOOKS += QPID_PROTON_REMOVE_USELESS_FILES
37 $(eval $(cmake-package))