libftdi: add explicit dependencies for host variant
[buildroot-gz.git] / package / neardal / neardal.mk
blobc3164ef0dae65bbea50b8d56d61c6153a3c8c4da
1 ################################################################################
3 # neardal
5 ################################################################################
7 NEARDAL_VERSION = 33b54a55032b047fd885a5eb3592c169c0056c49
8 NEARDAL_SITE = $(call github,connectivity,neardal,$(NEARDAL_VERSION))
9 NEARDAL_INSTALL_STAGING = YES
10 NEARDAL_LICENSE = GPLv2
11 NEARDAL_LICENSE_FILES = COPYING
13 NEARDAL_DEPENDENCIES = host-pkgconf dbus dbus-glib
14 NEARDAL_AUTORECONF = YES
16 # Either readline or libedit are needed, and the Config.in file
17 # guarantees at least one of them is enabled
18 ifeq ($(BR2_PACKAGE_READLINE),y)
19 NEARDAL_DEPENDENCIES += readline
20 else ifeq ($(BR2_PACKAGE_LIBEDIT),y)
21 NEARDAL_DEPENDENCIES += libedit
22 endif
24 # Both readline and libedit link with ncurses but the configure script
25 # forgets to take that into account, causing the detection to fail
26 # when linking statically
27 ifeq ($(BR2_STATIC_LIBS),y)
28 NEARDAL_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs ncurses`"
29 endif
31 define NEARDAL_INSTALL_NCL
32 $(INSTALL) -m 0755 -D $(@D)/ncl/ncl $(TARGET_DIR)/usr/bin/ncl
33 endef
35 ifeq ($(BR2_PACKAGE_NEARDAL_NCL),y)
36 NEARDAL_POST_INSTALL_TARGET_HOOKS += NEARDAL_INSTALL_NCL
37 endif
39 $(eval $(autotools-package))