zynq_zed: bump U-Boot to xilinx-v2016.2
[buildroot-gz.git] / package / autofs / autofs.mk
blob396cf85fbe185c0430410f68f7802242ed3b9536
1 ################################################################################
3 # autofs
5 ################################################################################
7 AUTOFS_VERSION = 5.1.2
8 AUTOFS_SOURCE = autofs-$(AUTOFS_VERSION).tar.xz
9 AUTOFS_SITE = $(BR2_KERNEL_MIRROR)/linux/daemons/autofs/v5
10 AUTOFS_LICENSE = GPLv2+
11 AUTOFS_LICENSE_FILES = COPYING COPYRIGHT
12 AUTOFS_DEPENDENCIES = host-flex host-bison
13 # For 0002-autofs-configure-check-for-clock_gettime-in-librt.patch
14 AUTOFS_AUTORECONF = YES
16 # autofs looks on the build machine for the path of modprobe, so tell
17 # it explicitly where it will be located on the target.
18 AUTOFS_CONF_ENV = \
19 ac_cv_path_KRB5_CONFIG=no \
20 ac_cv_path_MODPROBE=/sbin/modprobe
22 # instead of looking in the PATH like any reasonable package, autofs
23 # configure looks only in an hardcoded search path for host tools,
24 # which we have to override with --with-path.
25 AUTOFS_CONF_OPTS = \
26 --disable-mount-locking \
27 --enable-ignore-busy \
28 --without-openldap \
29 --without-sasl \
30 --with-path="$(BR_PATH)" \
31 --with-hesiod=no
33 AUTOFS_MAKE_ENV = DONTSTRIP=1
35 $(eval $(autotools-package))