libasplib: add url to gcc bug report
[buildroot-gz.git] / package / babeld / babeld.mk
blobd718237d98d5cba9fda520580d0db5e51adeac9f
1 ################################################################################
3 # babeld
5 ################################################################################
7 BABELD_VERSION = 1.7.1
8 BABELD_SITE = http://www.pps.univ-paris-diderot.fr/~jch/software/files
9 BABELD_LICENSE = MIT
10 BABELD_LICENSE_FILES = LICENCE
12 define BABELD_BUILD_CMDS
13 $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
14 endef
16 define BABELD_INSTALL_TARGET_CMDS
17 $(INSTALL) -D -m 755 $(@D)/babeld $(TARGET_DIR)/usr/sbin/babeld
18 endef
20 define BABELD_INSTALL_INIT_SYSV
21 $(INSTALL) -D -m 755 package/babeld/S50babeld \
22 $(TARGET_DIR)/etc/init.d/S50babeld
23 endef
25 define BABELD_INSTALL_INIT_SYSTEMD
26 $(INSTALL) -D -m 644 package/babeld/babeld.service \
27 $(TARGET_DIR)/usr/lib/systemd/system/babeld.service
29 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
31 ln -fs ../../../../usr/lib/systemd/system/babeld.service \
32 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/babeld.service
33 endef
35 $(eval $(generic-package))