1 ################################################################################
5 ################################################################################
8 BABELD_SITE
= http
://www.pps.univ-paris-diderot.fr
/~jch
/software
/files
10 BABELD_LICENSE_FILES
= LICENCE
12 define BABELD_BUILD_CMDS
13 $(MAKE
) -C
$(@D
) $(TARGET_CONFIGURE_OPTS
)
16 define BABELD_INSTALL_TARGET_CMDS
17 $(INSTALL
) -D
-m
755 $(@D
)/babeld
$(TARGET_DIR
)/usr
/sbin
/babeld
20 define BABELD_INSTALL_INIT_SYSV
21 $(INSTALL
) -D
-m
755 package
/babeld
/S50babeld \
22 $(TARGET_DIR
)/etc
/init.d
/S50babeld
25 define BABELD_INSTALL_INIT_SYSTEMD
26 $(INSTALL
) -D
-m
644 package
/babeld
/babeld.service \
27 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/babeld.service
29 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
31 ln
-fs ..
/..
/..
/..
/usr
/lib
/systemd
/system
/babeld.service \
32 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/babeld.service
35 $(eval
$(generic-package
))