libasplib: add url to gcc bug report
[buildroot-gz.git] / package / libpjsip / libpjsip.mk
blobb0d06099bb2f4779d2a319d4c053a3dc1e8d0797
1 ################################################################################
3 # libpjsip
5 ################################################################################
7 LIBPJSIP_VERSION = 2.6
8 LIBPJSIP_SOURCE = pjproject-$(LIBPJSIP_VERSION).tar.bz2
9 LIBPJSIP_SITE = http://www.pjsip.org/release/$(LIBPJSIP_VERSION)
10 LIBPJSIP_DEPENDENCIES = libsrtp
11 LIBPJSIP_LICENSE = GPLv2+
12 LIBPJSIP_LICENSE_FILES = COPYING
13 LIBPJSIP_INSTALL_STAGING = YES
14 LIBPJSIP_MAKE = $(MAKE1)
16 LIBPJSIP_CFLAGS = $(TARGET_CFLAGS) -DPJ_HAS_IPV6=1
18 # relocation truncated to fit: R_68K_GOT16O
19 ifeq ($(BR2_m68k_cf),y)
20 LIBPJSIP_CFLAGS += -mxgot
21 endif
23 LIBPJSIP_CONF_ENV = \
24 LD="$(TARGET_CC)" \
25 CFLAGS="$(LIBPJSIP_CFLAGS)"
27 LIBPJSIP_CONF_OPTS = \
28 --disable-sound \
29 --disable-gsm-codec \
30 --disable-speex-codec \
31 --disable-speex-aec \
32 --disable-resample \
33 --disable-video \
34 --disable-opencore-amr \
35 --disable-g7221-codec \
36 --disable-ilbc-codec \
37 --disable-libwebrtc \
38 --disable-opus \
39 --disable-oss \
40 --disable-ext-sound \
41 --disable-small-filter \
42 --disable-large-filter \
43 --disable-g711-codec \
44 --disable-l16-codec \
45 --disable-g722-codec \
46 --disable-libsamplerate \
47 --disable-sdl \
48 --disable-ffmpeg \
49 --disable-v4l2 \
50 --disable-openh264 \
51 --disable-libyuv \
52 --disable-ipp \
53 --disable-ssl \
54 --disable-silk \
55 --with-external-srtp
57 # Note: aconfigure.ac is broken: --enable-epoll or --disable-epoll will
58 # both enable it. But that's OK, epoll is better than the alternative,
59 # so we want to use it.
60 LIBPJSIP_CONF_OPTS += --enable-epoll
62 ifeq ($(BR2_PACKAGE_OPENSSL),y)
63 LIBPJSIP_DEPENDENCIES += openssl
64 LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
65 else
66 LIBPJSIP_CONF_OPTS += --disable-ssl
67 endif
69 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
70 LIBPJSIP_DEPENDENCIES += util-linux
71 endif
73 $(eval $(autotools-package))