package/iputils: patch ping to link against libm
[buildroot-gz.git] / package / leafnode2 / leafnode2.mk
blob5b9b85482b269b97d971471b8343d507db87d922
1 ################################################################################
3 # leafnode2
5 ################################################################################
7 LEAFNODE2_VERSION = 2.0.0.alpha20140727b
8 LEAFNODE2_SOURCE = leafnode-$(LEAFNODE2_VERSION).tar.bz2
9 LEAFNODE2_SITE = http://www.dt.e-technik.tu-dortmund.de/~ma/leafnode/beta
10 LEAFNODE2_LICENSE = LGPLv2.1
11 LEAFNODE2_LICENSE_FILES = COPYING COPYING.LGPL
12 LEAFNODE2_DEPENDENCIES = host-pcre pcre
14 LEAFNODE2_CONF_ENV = \
15 PCRECONFIG="$(STAGING_DIR)/usr/bin/pcre-config"
17 # --enable-runas-user use 'news' as default but the configure stop
18 # if news doesn't exist on the build host.
19 # Use 'root' while cross-compiling
20 LEAFNODE2_CONF_OPTS = \
21 --sysconfdir=/etc/leafnode2 \
22 --enable-spooldir=/var/spool/news \
23 --enable-runas-user=root
25 # Leafnode2 needs the host version of b_sortnl during
26 # compilation. Instead of creating a seperate host package and
27 # installing b_sortnl to $(HOST_DIR) this binary is compiled
28 # on-the-fly, host-pcre is needed for this
29 define LEAFNODE2_BUILD_SORTNL_TOOL
30 cd $(@D); \
31 $(HOSTCC) $(HOST_CFLAGS) -o b_sortnl_host \
32 arc4random.c mergesort.c b_sortnl.c critmem_malloc.c \
33 critmem_realloc.c -DHAVE_CONFIG_H -I$(HOST_DIR)/usr/include \
34 -L $(HOST_DIR)/usr/lib -Wl,-rpath,$(HOST_DIR)/usr/lib -lpcre
35 endef
37 LEAFNODE2_PRE_BUILD_HOOKS += LEAFNODE2_BUILD_SORTNL_TOOL
39 define LEAFNODE2_USERS
40 news -1 news -1 * - - - Leafnode2 daemon
41 endef
43 $(eval $(autotools-package))