1 ################################################################################
5 ################################################################################
8 ALLJOYN_VERSION
= $(ALLJOYN_REV
).00a
9 ALLJOYN_SOURCE
= alljoyn-
$(ALLJOYN_VERSION
)-src.
tar.gz
10 ALLJOYN_SITE
= https
://mirrors.kernel.org
/allseenalliance
/alljoyn
/$(ALLJOYN_REV
)
11 # See https://allseenalliance.org/alliance/ip-policy
14 ALLJOYN_DEPENDENCIES
= host-scons libcap openssl
15 ALLJOYN_INSTALL_STAGING
= YES
17 ALLJOYN_CRYPTO
= openssl
19 # AllJoyn can be compiled in debug or release mode. By default, AllJoyn is built
21 ALLJOYN_VARIANT
= release
23 ALLJOYN_BINDINGS
= c
,cpp
25 # By setting openwrt for OS and CPU, AllJoyn cross-compilation can be finely
26 # tuned through TARGET_xxx options. All TARGET_xxx variables must be defined
27 # otherwise compilation will fail.
28 # CROSS_COMPILE option should not be used as it works only for linux/ARM.
32 # AllJoyn installs everything in this relative path
33 ALLJOYN_DISTDIR
= build
/$(ALLJOYN_OS
)/$(ALLJOYN_CPU
)/$(ALLJOYN_VARIANT
)/dist/
35 ALLJOYN_SCONS_OPTS
= \
40 VARIANT
=$(ALLJOYN_VARIANT
) \
42 CRYPTO
=$(ALLJOYN_CRYPTO
) \
43 BINDINGS
=$(ALLJOYN_BINDINGS
) \
44 TARGET_CFLAGS
="$(TARGET_CFLAGS)" \
45 TARGET_CPPFLAGS
="$(TARGET_CPPFLAGS)" \
46 TARGET_LINKFLAGS
="$(TARGET_LINKFLAGS)" \
47 TARGET_CC
="$(TARGET_CC)" \
48 TARGET_CXX
="$(TARGET_CXX)" \
49 TARGET_LD
="$(TARGET_LD)" \
50 TARGET_LINK
="$(TARGET_CXX)" \
51 TARGET_AR
="$(TARGET_AR)" \
52 TARGET_RANLIB
="$(TARGET_RANLIB)" \
53 TARGET_PATH
="$(BR_PATH)"
55 define ALLJOYN_BUILD_CMDS
56 cd
$(@D
); $(SCONS
) $(ALLJOYN_SCONS_OPTS
)
59 define ALLJOYN_INSTALL_STAGING_CMDS
60 cp
-a
$(@D
)/$(ALLJOYN_DISTDIR
)/*/lib
/lib
* $(STAGING_DIR
)/usr
/lib
/
61 cp
-a
$(@D
)/$(ALLJOYN_DISTDIR
)/*/inc
/* $(STAGING_DIR
)/usr
/include/
64 # Only install alljoyn dynamic libraries into target directory
65 define ALLJOYN_INSTALL_TARGET_CMDS
66 cp
-a
$(@D
)/$(ALLJOYN_DISTDIR
)/*/lib
/lib
*.so
* $(TARGET_DIR
)/usr
/lib
/
69 $(eval
$(generic-package
))