1 ################################################################################
5 ################################################################################
8 CHRONY_SITE
= http
://download.tuxfamily.org
/chrony
10 CHRONY_LICENSE_FILES
= COPYING
14 --host-machine
=$(BR2_ARCH
) \
19 ifeq ($(BR2_PACKAGE_LIBCAP
),y
)
20 CHRONY_DEPENDENCIES
+= libcap
22 CHRONY_CONF_OPTS
+= --without-libcap
25 ifeq ($(BR2_PACKAGE_LIBNSS
),y
)
26 CHRONY_DEPENDENCIES
+= host-pkgconf libnss
28 CHRONY_CONF_OPTS
+= --without-nss
31 ifeq ($(BR2_PACKAGE_READLINE
),y
)
32 CHRONY_DEPENDENCIES
+= readline
34 CHRONY_CONF_OPTS
+= --disable-readline
37 # If pps-tools is available, build it before so the package can use it
38 # (HAVE_SYS_TIMEPPS_H).
39 ifeq ($(BR2_PACKAGE_PPS_TOOLS
),y
)
40 CHRONY_DEPENDENCIES
+= pps-tools
43 define CHRONY_CONFIGURE_CMDS
44 cd
$(@D
) && $(TARGET_CONFIGURE_OPTS
) .
/configure
$(CHRONY_CONF_OPTS
)
47 define CHRONY_BUILD_CMDS
48 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
)
51 define CHRONY_INSTALL_TARGET_CMDS
52 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) DESTDIR
="$(TARGET_DIR)" install
55 define CHRONY_INSTALL_INIT_SYSV
56 $(INSTALL
) -D
-m
755 package
/chrony
/S49chrony
$(TARGET_DIR
)/etc
/init.d
/S49chrony
59 define CHRONY_INSTALL_INIT_SYSTEMD
60 $(INSTALL
) -D
-m
644 package
/chrony
/chrony.service \
61 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/chrony.service
62 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
63 ln
-sf ..
/..
/..
/..
/usr
/lib
/systemd
/system
/chrony.service \
64 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/chrony.service
67 $(eval
$(generic-package
))