1 #######################################################################################
5 #######################################################################################
8 CXXTEST_SITE
= https
://github.com
/CxxTest
/cxxtest
/releases
/download
/$(CXXTEST_VERSION
)
9 CXXTEST_LICENSE
= LGPLv3
10 CXXTEST_LICENSE_FILES
= COPYING
11 CXXTEST_INSTALL_STAGING
= YES
12 CXXTEST_INSTALL_TARGET
= NO
13 CXXTEST_DEPENDENCIES
= host-cxxtest
14 HOST_CXXTEST_SETUP_TYPE
= setuptools
15 HOST_CXXTEST_SUBDIR
= python
17 # Copy CxxTest header files to staging directory
18 define CXXTEST_INSTALL_STAGING_CMDS
19 $(INSTALL
) -m
755 -d
$(STAGING_DIR
)/usr
/include/cxxtest
20 $(INSTALL
) -m
644 -t
$(STAGING_DIR
)/usr
/include/cxxtest
$(@D
)/cxxtest
/*
23 # CxxTest uses python infrastructure as the build system. It consists of two parts:
24 # 1. cxxtestgen tool to process tests defined in header files to generate C++ source
25 # files. cxxtestgen is built as a host package, so that it can be used natively.
26 # 2. A set of header files which are installed in staging directory. This will be
27 # used in cross-compiling test harness to generate executable which will run on target.
29 $(eval
$(generic-package
))
30 $(eval
$(host-python-package
))